Questions by giorgino2007-06-22
NEXTO OTG not compatible with MacOS X 10.4.10 (last version avalaible)
My iMac Intel with last Apple MacOS X update (10.4.10) don't see my adorable NEXTO OTG.
I'm desperate! Help me!
The trouble is confirmed from all NEXTO Mac-User-

Update NEXTO firmware please! As soon as possible! :)

Thank you.

giorgino - Italy
Password

Reply Add your reply

Answer by NextoDI2007-06-25
Now, we are testing MAC OS 10.4.10 version. Please wait for a while.
Thanks
Password

Your answer

Fill in the details